На какой версии Debian основаны различные версии Ubuntu?

У меня есть несколько пакетов программного обеспечения, настроенных для Ubuntu 10.04, 10.10 и 12.10, но теперь я должен установить их на Debian Squeeze. Мне не удалось найти в Google сопоставление между конкретными версиями Ubuntu и Debian. Может кто-нибудь здесь помочь?

В частности, я хочу знать, какая версия Ubuntu соответствует Debian Squeeze.

Вы можете найти версию Debian, на которой основана ваша версия Ubuntu, в файле: /etc/debian_version

С 10.04 по 21.04:

Ubuntu            Debian  21.10  impish     bullseye/ sid   - 1121.04  hirsute    bullseye/ sid   20.10  groovy     bullseye/ sid20.04  focal      bullseye/ sid19.10  eoan       buster  / sid   - 1019.04  disco      buster  / sid18.10  cosmic     buster  / sid18.04  bionic     buster  / sid17.10  artful     stretch / sid   - 917.04  zesty      stretch / sid16.10  yakkety    stretch / sid16.04  xenial     stretch / sid15.10  wily       jessie  / sid   - 815.04  vivid      jessie  / sid14.10  utopic     jessie  / sid14.04  trusty     jessie  / sid13.10  saucy      wheezy  / sid   - 713.04  raring     wheezy  / sid12.10  quantal    wheezy  / sid12.04  precise    wheezy  / sid11.10  oneiric    wheezy  / sid11.04  natty      squeeze / sid   - 610.10  maverick   squeeze / sid10.04  lucid      squeeze / sid

Сид это дистрибутив для разработки Debian.

Вы можете узнать содержимое файла без установки всей системы, просмотрев исходные тексты для пакет basefiles на панели запуска.

К сожалению, нет прямого сопоставления / etc / debian_version, как упомянуто в ответе Джейкоба, что дает приблизительное представление, но на самом деле оно отражает только один пакет, и указанный пакет - это пакет, который локально изменен в Ubuntu, поэтому не будет автоматически извлечен из Debian.

В частности, Ubuntu часто опережает Debian по основным пакетам, таким как libc6. Попытка установить пакет, созданный на Ubuntu, на современную версию Debian, скорее всего, приведет к ошибкам версии libc6.

Согласно с https://superuser.com/questions/407745/wrong-libc6-version-in-debian-squeeze-can-i-go-back Debian squeeze имел libc6 2.11 . Согласно с http://web.archive.org/web/20110705212424/http://packages.ubuntu.com/search ?ключевые слова=libc6 ubuntu 10.04 lucid также имел libc6 2.11. Таким образом, пакеты для 10.4 lucid, скорее всего, будут работать на Squeeze.

В зависимости от того, какие другие библиотеки нужны вашей программе, вы вполне можете обнаружить, что требуется конкретная сборка для Debian squeeze.

Если мы можем поверить [этому сайту](Sign in · GitLab /). Затем 10.04

Связанные: How can I find out what version of Debian a particular version of Ubuntu is based on? - Unix & Linux Stack Exchange