Отказано в разрешении для root@localhost для подключения по ssh

Я только что установил Ubuntu 14.04 и включил его. Затем я захотел настроить свой сервер, поэтому попробовал Этот руководство.

Когда я отдам команду:

ssh root@localhost

Я получаю: В разрешении отказано, пожалуйста, попробуйте еще раз.Я вошел в систему как пользователь root с помощью команды :

sudo -i

Я также попробовал то же самое, войдя в систему через:

sudo -s

Я использую тот же пароль, что и для входа в систему в качестве пользователя, но все равно получаю то же сообщение об ошибке.

Не мог бы кто-нибудь помочь мне здесь?

PS: Я заглянул в Этот вопрос но, похоже, у меня это не сработало.

По умолчанию SSH-сервер запрещает root-пользователю входить в систему на основе пароля. В /etc/ssh/sshd_config, если существует следующая строка, возможно, закомментированная (с помощью # впереди):

PermitRootLogin without-password

Затем измените его на следующий, раскомментировав, если это необходимо (удалите # впереди):

PermitRootLogin yes

И перезапустите SSH:

sudo service ssh restart

Или же вы можете использовать SSH-ключи. Если у вас его нет, создайте его с помощью ssh-keygen (придерживайтесь значения ключа по умолчанию и пропустите пароль, если вам так хочется). Затем сделайте sudo -s (или каким бы ни был ваш предпочтительный метод получения root), и добавьте SSH-ключ к /root/.ssh/authorized_keys:

cat /home/user/.ssh/id_rsa.pub >> /root/.ssh/authorized_keys

В некоторых случаях, после изменения,

PermitRootLogin yes

необходимо проверить эту конфигурацию:

DenyUsers rootAllowUsers saeid

и чтобы включить вход в систему, необходимо изменить на:

#DenyUsers rootAllowUsers root OtherUser

Если вы не указали пароль для root, и вы пытаетесь запустить команду на spark или haddop, например ./sbin/stop-all.sh or./sbin/start-all.sh . Если у вас нет пароля root, вы можете настроить его с помощью

sudo passwd

и команды на огонь.

У меня была похожая проблема с этим. Мне нужно было два ПК, один на Ubuntu, а другой на Arch, чтобы синхронизировать файлы через Unison, но столкнулся с той же ошибкой отказа в разрешении. Просто ради тех, у кого такая же проблема, как и у меня, вот что я сделал:

Во-первых: Установлена одна и та же версия Unison на обоих компьютерах. Это было немного сложно, поскольку тот, который был доступен в центре программного обеспечения, уступал тому, что было легко доступно для Arch. Итак, я не смог найти более высокую версию для Ubuntu, поэтому я заменил версию на Arch на более низкую. Нашел один здесь: http://zdia.de/downloads/unison-2.40.102-linux-x86_64. Та же версия находится в центре программного обеспечения для Ubuntu.

Второе: Следуйте инструкциям отсюда:https://www.howtoforge.com/setting-up-unison-file-synchronization-between-two-servers-on-debian-squeeze(Примечание: Arch был моим сервером 1, а Ubuntu - моим сервером 2.)

Я столкнулся с проблемой на шаге 3, когда попытался выполнить ssh-копирование. Но это было решено путем изменения "id_dsa.pub" на "id_rsa.pub" в "ssh-copy-id -i $HOME/.ssh/id_dsa.pub root@192.168.0.101 " линия. Вероятно, это моя вина, так как я думаю, что забыл добавить "-t dsa". В любом случае, сначала попробуйте исходную команду. если вы получаете сообщение об ошибке, затем перейдите на rsa.

Выполнив описанные выше действия, я обнаружил, что все еще не могу заставить Unison подключиться к другому серверу, и я также не могу войти в систему (без Unison) через ssh на другой сервер. Наконец, после нескольких часов поиска в Google, я попал на эту страницу, и ответ, данный моему Муру, скрепил сделку.

После его применения я теперь мог войти через SSH на сервер 2.

Так что я запустил Unison, и исправил настройки профиля, и viola!

TL; DR и хотел бы закодировать в sed чтобы обойти permission denied в ssh

sed -i s/#\(PermitRootLogin*\).*/\1 yes/ /etc/ssh/sshd_config

Я столкнулся с аналогичной проблемой при входе в систему qemu.
Одна из проблем может заключаться в том, что authorized_keys на удаленном компьютере не совпадает с ключом хост-компьютера, с которого вы пытаетесь войти в систему.

Копирование id_rsa.pub от хоста к authorized_keys удаленного КОМПЬЮТЕРА должно помочь.