Phpmyadmin не работает после того, как я его установил

Я использую ubuntu-11.04.

Я выполнил следующие действия на этом сайте:

Пока что мои apache2, php и mysql работают нормально, за исключением phpmyadmin... Всякий раз, когда я запускаю это:

http://localhost/phpmyadmin/

Я получаю эту ошибку в своем браузере:

не найдено

Запрошенный URL-адрес /phpmyadmin/ не был найден на этом сервере.


Apache/2.2.17 (Ubuntu) Сервер на локальном хосте Порт 80

Пожалуйста, прочтите этот раздел в Ubuntu wiki. Вам нужно будет настроить свой apache2.conf, чтобы заставить phpMyAdmin работать.

gksu gedit /etc/apache2/apache2.conf

Затем добавьте следующую строку в конец файла.

Include /etc/phpmyadmin/apache.conf

Затем перезапустите apache

/etc/init.d/apache2 restart

Пробовал разные способы.

Наконец-то это, это из документация ubuntu, сработало на меня:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.confsudo a2enconf phpmyadminsudo service apache2 reload

Ubuntu 16.04

После установки и настройки пользователя и пароля в mysql и phpmyadmin выполните следующую команду

sudo apt install php-gettext

Сработало на меня...

Правка1Если вам просто нужно apache, phpMyAdmin и MySQL просто в среду веб-приложения, тогда я предлагаю, например, установить все три для вас, и тогда вы готовы перейти Вот ссылка

Установщики и загрузки XAMPP | Apache Friends

Не паникуйте! Просто запустите следующий код с правами root в терминале

sudo ln -s /usr/share/phpmyadmin /var/www

Я столкнулся с той же проблемой, я исправил ее, запустивsudo dpkg-reconfigure phpmyadmin

введите новое имя пользователя и пароль

Вам нужно найти, где phpmyadmin находится, например locate phpmyadmin, некоторые из них вернут местоположение, например /usr/share/phpmyadmin.

Затем вы можете связать его символической ссылкой следующим образом: sudo ln -s /usr/share/phpmyadmin /var/www

Начиная с Ubuntu 14.04 и выше, /var/www это больше не работа, а /var/www/html. например, sudo ln -s /usr/share/phpmyadmin /var/www/html

Ссылка: Где разместить мой локальный веб-сайт, начиная с версии apache2 2.4.7?

Я перепробовал все вышеперечисленные методы, и они у меня не сработали. Наконец-то это сработало.

Откройте терминал и переключитесь на суперпользователя, используя команду: sudo su

После установки phpmyadmin с использованием инструкций, приведенных в ссылка, открыть /etc/apache2/conf-available.

Там вы найдете файл с именем phpmyadmin.conf. Скопируйте его в /etc/apache2/conf-enabled. Или просто используйте команду

sudo cp /etc/apache2/conf-available /etc/apache2/conf-enabled

Перезапустить apache2 (sudo service apache2 restart), а затем откройте ссылку localhost/phpmyadmin в браузере.

наконец, это работает для ubuntu 14.04 LTS

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.confsudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadminsudo service apache2 restart

теперь введите localhost/phpmyadmin в веб-браузере.

sudo sed -i '$ a\Include /etc/phpmyadmin/apache.conf' /etc/apache2/apache2.conf && sudo service apache2 restart && sudo apt-get install php-gettext`

Протестировано и работает. Запуск этого должен решить проблему для всех, кто хочет 1 лайнер.

Я столкнулся с той же проблемой.

Сначала проверьте, вызывается ли каталог /usr/share/phpmyadmin/ существует. Если это произойдет, просто переместите его в /var/www/phpmyadmin выполнив эту команду:

mv /usr/share/phpmyadmin /var/www/phpmyadmin

Откройте свой браузер и откройте http://localhost/phpmyadmin. Теперь это должно сработать.

Вы перезапустили сервер apache: /etc/init.d/apache2 restart

Подумайте, проверяя ответ, предоставленный @sangharsh.