"Следующие пакеты были установлены автоматически и больше не требуются", когда я пытаюсь установить gnuplot

Я хочу установить gnuplot на Ubuntu 12.04. Однако он всегда завершается неудачей со следующим журналом:

Reading package lists... DoneBuilding dependency tree       Reading state information... Donegnuplot is already the newest version.The following packages were automatically installed and are no longer required:   language-pack-zh-hans language-pack-kde-en language-pack-kde-zh-hans   language-pack-kde-en-base kde-l10n-engb kde-l10n-zhcn   language-pack-zh-hans-base firefox-locale-zh-hans   language-pack-kde-zh-hans-baseUse 'apt-get autoremove' to remove them.0 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.

Что я могу сделать, чтобы устранить эту проблему?

Скорее всего, ничего. Выходные данные сообщают вам, что gnuplot is already the newest version.

Ub-lx

Вы можете попробовать эту команду для установки GNU plot и поработать над ней

sudo apt-get install gnuplot-x11

и с помощью этого pdf-файла вы можете изучить GNU plot: http://fig.if.usp.br /~lucmod/советы/gnuplotbook.pdf

просто вопрос

sudo apt-get install gnuplot

который по умолчанию будет использовать серверную часть QT, поскольку X11 становится слишком длинным в зубах

5.0.1 из источника 14.04:

cvs -d:pserver:anonymous@gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot logincvs -z3 -d:pserver:anonymous@gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot co -P gnuplotcd gnuplotcvs update -r Release_5_0_1sudo apt-get build-dep gnuplotsudo apt-get install lua5.2./prepare./configuretime makesudo make installgnuplot --version

15.04 имеет gnuplot5-x11 пакет.

Пакеты GNUplot:

gnuplot-noxgnuplot-qtgnuplot-x11

Для установки вы можете использовать

sudo apt install <selected-package>