Как остановить автоматическое обновление времени через терминал?

В этом вопросе показано, как остановить автоматическое обновление времени (и переключиться на ручное):

Как остановить автоматическое обновление времени?

Я хочу сделать именно это, но я могу подключиться только по ssh к своей машине, поэтому мне нужно внести это изменение через терминал. Есть ли какой-нибудь способ сделать это?

GNOME Automatic Date & Time не использует службу ntp, которую можно установить через sudo apt-get install ntp. Поэтому остановка или удаление службы не помогает.

Systemd timedatectl используется, поэтому одна команда для выключения

timedatectl set-ntp 0

и одна команда для включения

timedatectl set-ntp 1

Пример

enter image description here

% timedatectl set-ntp 1

enter image description here

или через timedatectl status

% timedatectl status      Local time: Do 2015-10-08 18:17:17 CEST  Universal time: Do 2015-10-08 16:17:17 UTC        RTC time: Do 2015-10-08 16:17:17       Time zone: Europe/Berlin (CEST, +0200)     NTP enabled: noNTP synchronized: yes RTC in local TZ: no      DST active: yes Last DST change: DST began at                  So 2015-03-29 01:59:59 CET                  So 2015-03-29 03:00:00 CEST Next DST change: DST ends (the clock jumps one hour backwards) at                  So 2015-10-25 02:59:59 CEST                  So 2015-10-25 02:00:00 CET% timedatectl set-ntp 1% timedatectl status      Local time: Do 2015-10-08 18:17:35 CEST  Universal time: Do 2015-10-08 16:17:35 UTC        RTC time: Do 2015-10-08 16:17:35       Time zone: Europe/Berlin (CEST, +0200)     NTP enabled: yesNTP synchronized: yes RTC in local TZ: no      DST active: yes Last DST change: DST began at                  So 2015-03-29 01:59:59 CET                  So 2015-03-29 03:00:00 CEST Next DST change: DST ends (the clock jumps one hour backwards) at                  So 2015-10-25 02:59:59 CEST                  So 2015-10-25 02:00:00 CET

В операционной системе systemd, такой как Ubuntu 15.04, используйте timedatectl утилита, которая выполняет те же вызовы RPC настольной шины, что и утилита GNOME control center.:

timedatectl set-ntp false

Дальнейшее чтение

  • timedatectl. Страницы руководства Ubuintu 15.04. Канонический.
  • timedatectl. страницы руководства systemd. Freedesktop.org .

То, что вы ищете, не является ntpd который не установлен по умолчанию. Это - if-up.d сценарий, который обновляется во время выполнения всякий раз, когда активируется сетевой интерфейс.

dconf watch / не показывает ничего, кроме inotifywait -m -r /etc/ будем делать.

/etc/network/if-up.d/ MOVED_FROM ntpdate/etc/network/if-up.d/ MOVED_TO ntpdate.disabled

Он принадлежит пакету ntpdate.

$ dpkg -S /etc/network/if-up.d/ntpdatentpdate: /etc/network/if-up.d/ntpdate

Поэтому, чтобы отключить обновление времени, переименуйте этот файл так же, как это делает центр управления:

sudo mv /etc/network/if-up.d/ntpdate /etc/network/if-up.d/ntpdate.disabled

Возможный дубликат как мне отключить ntpd?

@AizuddinZali Я бы сказал, что это не так - поскольку он получает ошибки, сообщающие ему, что ntp.service не загружен и “sudo / etc / init.d / ntp stop” не работает - см. Комментарии к моему ответу

да, это связано с настройкой времени и даты gnome.

Правильно, мне просто интересно, есть ли способ изменить настройки с терминала, или где-то есть файл, в котором мне нужно изменить строку? Я попробовал “conf watch /”, пока менял настройки в графическом интерфейсе, но он ничего не показал (но изменил некоторые другие настройки)

автоматическая дата и время ntp и GNOME ** - это не** одно и то же.

И это не dconf вещь o_O – очень интересно

Вы можете заблокировать порт на исходящем брандмауэре.