Каков пакет разработки для Qt5 в 14.04

Я хочу создать пример Qt5 на своем настольном компьютере. Я установил qt5-default и qtdeclarative5-dev, но я все еще получаю эту ошибку:

Project ERROR: Unknown module(s) in QT: quick qml

Какой пакет должен быть установлен для компиляции? В Qt4 раза это было просто libqt4-dev

Список всех пакетов разработки Qt5, доступных в Ubuntu.

Qt module           dev package                         lib package-------------------------------------------------------------------------bluetooth           qtconnectivity5-dev                 libqt5bluetooth5concurrent          qtbase5-dev                         libqt5concurrent5connectivity        qtmobility-dev                      libqtconnectivity1contacts            qtmobility-dev                      libqt5contacts5core                qtbase5-dev                         libqt5core5adbus                qtbase5-dev                         libqt5dbus5designer            qttools5-dev                        libqt5designer5designercomponents  qttools5-dev                        libqt5designercomponents5feedback            qtmobility-dev                      libqt5feedback5gallery             qtmobility-dev                      libqtgallery1gui                 qtbase5-dev                         libqt5gui5help                qttools5-dev                        libqt5help5location            qtmobility-dev                      libqt5location5multimedia          qtmultimedia5-dev                   libqt5multimedia5multimediakit       qtmobility-dev                      libqtmultimediakit1network             qtbase5-dev                         libqt5network5networkauth         libqt5networkauth5-dev              libqt5networkauth5nfc                 qtconnectivity5-dev                 libqt5nfc5opengl              libqt5opengl5-dev                   libqt5opengl5organizer           qtmobility-dev                      libqt5organizer5positioning         qtpositioning5-dev                  libqt5positioning5printsupport        qtbase5-dev                         libqt5printsupport5publishsubscribe    qtmobility-dev                      libqt5publishsubscribe5qml                 qtdeclarative5-dev                  libqt5qml5quick               qtdeclarative5-dev                  libqt5quick5quickparticles      qtdeclarative5-dev                  libqt5quickparticles5quicktest           qtdeclarative5-dev                  libqt5quicktest5quickwidgets        qtdeclarative5-dev                  libqt5quickwidgets5script              qtscript5-dev                       libqt5script5scripttools         qtscript5-dev                       libqt5scripttools5sensors             qtmobility-dev, libqt5sensors5-dev  libqt5sensors5serialport          libqt5serialport5-dev               libqt5serialport5serviceframework    qtmobility-dev                      libqt5serviceframework5sql                 qtbase5-dev                         libqt5sql5svg                 libqt5svg5-dev                      libqt5svg5systeminfo          qtmobility-dev                      libqt5systeminfo5test                qtbase5-dev                         libqt5test5uitools             qttools5-dev                        ?versit              qtmobility-dev                      libqtversit1webchannel          ?                                   ?webkit              libqt5webkit5-dev                   libqt5webkit5websockets          libqt5websockets5-dev               libqt5websockets5widgets             qtbase5-dev                         libqt5widgets5x11extras           libqt5x11extras5-dev                libqt5x11extras5xml                 qtbase5-dev                         libqt5xml5xmlpatterns         libqt5xmlpatterns5-dev              libqt5xmlpatterns5

Вам необходимо установить

qtdeclarative5-dev

Ответ на название таков:

sudo apt-get install qtbase5-dev

Однако для вашей конкретной проблемы приведенные выше ответы верны.

sudo apt-get install qtdeclarative5-dev qml-module-qtquick-controls

Подтвердите установку с помощью::

qtchooser -print-env

Выходные данные могут выглядеть следующим образом (в зависимости от пакета, доступного для вашей версии Ubuntu):

QT_SELECT="default"QTTOOLDIR="/usr/lib/x86_64-linux-gnu/qt5/bin"QTLIBDIR="/usr/lib/x86_64-linux-gnu"

Ссылка здесь.

Вы можете получить список всех пакетов разработки Qt на выбор с помощью этой команды:

apt list "libqt5*-dev" "qt*-dev"

В нем будут показаны пакеты, доступные в ваших текущих репозиториях Ubuntu, на основе имен пакетов для пакетов разработки, которые можно увидеть в ответ от @gossen. Для получения подробной информации о команде и аналогичных командах, смотрите здесь.