Почему "(base)" появляется перед моим запросом терминала?

Мне интересно, почему у меня есть (base) слева от моей командной строки терминала.

Image of my prompt

Если я убегу source ~/.profile в терминале он исчезает.

Если я закрою этот терминал и снова открою новый терминал, (base) снова там.

Я хотел бы знать, что это такое.

Вот содержание моего .profile (исключая стандартные материалы $path и другие персонализированные вещи):

# if running bashif [ -n "$BASH_VERSION" ]; then    # include .bashrc if it exists    if [ -f "$HOME/.bashrc" ]; then        . "$HOME/.bashrc"    fifi

Вот содержимое моего файла .bashrc

# If not running interactively, don't do anythingcase $- in    *i*) ;;      *) return;;esac# don't put duplicate lines or lines starting with space in the history.# See bash(1) for more optionsHISTCONTROL=ignoreboth# append to the history file, don't overwrite itshopt -s histappend# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)HISTSIZE=1000HISTFILESIZE=2000# check the window size after each command and, if necessary,# update the values of LINES and COLUMNS.shopt -s checkwinsize# If set, the pattern "**" used in a pathname expansion context will# match all files and zero or more directories and subdirectories.#shopt -s globstar# make less more friendly for non-text input files, see lesspipe(1)[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"# set variable identifying the chroot you work in (used in the prompt below)if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then    debian_chroot=$(cat /etc/debian_chroot)fi# set a fancy prompt (non-color, unless we know we "want" color)case "$TERM" in    xterm-color|*-256color) color_prompt=yes;;esac# uncomment for a colored prompt, if the terminal has the capability; turned# off by default to not distract the user: the focus in a terminal window# should be on the output of commands, not on the prompt#force_color_prompt=yesif [ -n "$force_color_prompt" ]; then    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then    # We have color support; assume it's compliant with Ecma-48    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such    # a case would tend to support setf rather than setaf.)    color_prompt=yes    else    color_prompt=    fifiif [ "$color_prompt" = yes ]; then    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ 'else    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ 'fiunset color_prompt force_color_prompt# If this is an xterm set the title to user@host:dircase "$TERM" inxterm*|rxvt*)    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"    ;;*)    ;;esac# enable color support of ls and also add handy aliasesif [ -x /usr/bin/dircolors ]; then    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"    alias ls='ls --color=auto'    #alias dir='dir --color=auto'    #alias vdir='vdir --color=auto'    alias grep='grep --color=auto'    alias fgrep='fgrep --color=auto'    alias egrep='egrep --color=auto'fi# colored GCC warnings and errors#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'# some more ls aliasesalias ll='ls -alF'alias la='ls -A'alias l='ls -CF'# Add an "alert" alias for long running commands.  Use like so:#   sleep 10; alertalias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'# Alias definitions.# You may want to put all your additions into a separate file like# ~/.bash_aliases, instead of adding them here directly.# See /usr/share/doc/bash-doc/examples in the bash-doc package.if [ -f ~/.bash_aliases ]; then    . ~/.bash_aliasesfi# enable programmable completion features (you don't need to enable# this, if it's already enabled in /etc/bash.bashrc and /etc/profile# sources /etc/bash.bashrc).if ! shopt -oq posix; then  if [ -f /usr/share/bash-completion/bash_completion ]; then    . /usr/share/bash-completion/bash_completion  elif [ -f /etc/bash_completion ]; then    . /etc/bash_completion  fifi# added by Anaconda3 installer#export PATH="/home/jim/anaconda3/bin:$PATH". /home/jim/anaconda3/etc/profile.d/conda.shconda activate

Это также может быть связано с тем, что auto_activate_base имеет значение True. Вы можете проверить это с помощью следующей команды

conda config --show | grep auto_activate_base

Чтобы установить его в значение false

conda config --set auto_activate_base Falsesource ~/.bashrc

Чтобы повторно активировать, установите для него значение True

conda config --set auto_activate_base Truesource ~/.bashrc

Это, по-видимому, исходит от вашего conda окружающая среда. В частности, вы активируете conda от вашего ~/.bashrc следующим образом

# added by Anaconda3 installer#export PATH="/home/jim/anaconda3/bin:$PATH". /home/jim/anaconda3/etc/profile.d/conda.shconda activate

и conda activate предваряет ваше приглашение с помощью (<env-name->) - поскольку вы не указываете конкретную среду, по умолчанию используется значение (base).

Поведение задокументировано на Использование конфигурационного файла .condarc conda:

Изменить командную строку (changeps1)

При использовании activate измените командную строку с $PS1, чтобы включить активированную среду. Значение по умолчанию равно True.

пример:

changeps1: False

Поэтому, чтобы это исчезло, либо найдите и измените свой .condarc файл - или не активируйте conda с вашего ~/.bashrc файл.

(базовый) появляется из-за изменения среды conda.

Следующая команда скрывает (базовую) среду.

conda config --set changeps1 False

Чтобы деактивировать среду conda, введите:

conda deactivate

Это приведет к удалению (base) перед вашим приглашением Linux, как показано здесь:

(base) user@office-pc:~$

от вашего $HOME каталогecho "changeps1: False" >> .condarc

Похоже, это все еще экспериментальная функция Anaconda.

Чтобы вернуть его в нормальное состояние, вы можете выполнить команду:

conda init --reverse

Затем вам нужно закрыть текущее окно оболочки и открыть новое, чтобы увидеть изменения.

запустил приведенный ниже код, затем ввел conda deactivate и база исчезла.

echo >&2 "DeprecationWarning: 'source deactivate' is deprecated. Use 'conda deactivate'.""$_CONDA_ROOT/etc/profile.d/conda.sh" || return $?

конда деактивировать